#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?=[a-z]{4}$).*[ae]"
Local $sString = "akes" & @CRLF & _
"aejs" & @CRLF & _
"soae" & @CRLF & _
"skea" & @CRLF & _
"esao" & @CRLF & _
"sdhg" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)