re = /^(?=[a-z]{4}$).*[ae]/m
str = 'akes
aejs
soae
skea
esao
sdhg
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result