# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s).*\b(http:\/\/www\.blooming\.com\b.*?\.jpg\b).*/\1/;t' <<< "<div>Colorful Floor chair Series</div><div><br /></div><div>Soft
Suede</div><div><br /></div><div>Cute bubble design</div><div><br
/></div><div><p align=\"center\"><p align=\"center\"><img
src=\"http://gdetail.image-gemkt.com/186/716088198/2010/2/e3b117e2-a7bd-4d.GIF\"
/></div><div><p align=\"center\"><p align=\"center\"><img
src=\"http://www.blooming.com/image/xxxxxxxx.jpg\" /></div>"