import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s).*\\b(http://www\\.blooming\\.com\\b.*?\\.jpg\\b).*";
final String string = "<div>Colorful Floor chair Series</div><div><br /></div><div>Soft\n"
+ "Suede</div><div><br /></div><div>Cute bubble design</div><div><br\n"
+ "/></div><div><p align=\"center\"><p align=\"center\"><img\n"
+ "src=\"http://gdetail.image-gemkt.com/186/716088198/2010/2/e3b117e2-a7bd-4d.GIF\"\n"
+ "/></div><div><p align=\"center\"><p align=\"center\"><img\n"
+ "src=\"http://www.blooming.com/image/xxxxxxxx.jpg\" /></div>";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}