using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s).*\b(http://www\.blooming\.com\b.*?\.jpg\b).*";
string substitution = @"\1";
string input = @"<div>Colorful Floor chair Series</div><div><br /></div><div>Soft
Suede</div><div><br /></div><div>Cute bubble design</div><div><br
/></div><div><p align=""center""><p align=""center""><img
src=""http://gdetail.image-gemkt.com/186/716088198/2010/2/e3b117e2-a7bd-4d.GIF""
/></div><div><p align=""center""><p align=""center""><img
src=""http://www.blooming.com/image/xxxxxxxx.jpg"" /></div>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}