#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s).*\b(http://www\.blooming\.com\b.*?\.jpg\b).*"
Local $sString = "<div>Colorful Floor chair Series</div><div><br /></div><div>Soft" & @CRLF & _
"Suede</div><div><br /></div><div>Cute bubble design</div><div><br" & @CRLF & _
"/></div><div><p align="center"><p align="center"><img" & @CRLF & _
"src="http://gdetail.image-gemkt.com/186/716088198/2010/2/e3b117e2-a7bd-4d.GIF"" & @CRLF & _
"/></div><div><p align="center"><p align="center"><img" & @CRLF & _
"src="http://www.blooming.com/image/xxxxxxxx.jpg" /></div>"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)