using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b((?:https?|ftp):\/\/|www\.)([0-9A-Za-z]+\.?)+\b)";
string input = @"http://www.google.com
www.google.com";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}