// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\b((?:https?|ftp):\/\/|www\.)([0-9A-Za-z]+\.?)+\b)").unwrap();
let string = "http://www.google.com
www.google.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}