re = /(\b((?:https?|ftp):\/\/|www\.)([0-9A-Za-z]+\.?)+\b)/
str = 'http://www.google.com
www.google.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end