package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\b((?:https?|ftp):\/\/|www\.)([0-9A-Za-z]+\.?)+\b)`)
var str = `http://www.google.com
www.google.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}