package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(\d{3}\)\s*\d{3}[\s.-]?\d{4}\b|\*\d{3,10}|\d{3,10}\*`)
var str = ` (734) 555 1212
(734) 555.1212
(734) 555-1212
(734) 5551212
(734)5551212`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}