const regex = /\(\d{3}\)\s*\d{3}[\s.-]?\d{4}\b|\*\d{3,10}|\d{3,10}\*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(\\d{3}\\)\\s*\\d{3}[\\s.-]?\\d{4}\\b|\\*\\d{3,10}|\\d{3,10}\\*', 'g')
const str = ` (734) 555 1212
(734) 555.1212
(734) 555-1212
(734) 5551212
(734)5551212`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}