$re = '/\(\d{3}\)\s*\d{3}[\s.-]?\d{4}\b|\*\d{3,10}|\d{3,10}\*/';
$str = ' (734) 555 1212
(734) 555.1212
(734) 555-1212
(734) 5551212
(734)5551212';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);