import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(\\d{3}\\)\\s*\\d{3}[\\s.-]?\\d{4}\\b|\\*\\d{3,10}|\\d{3,10}\\*";
final String string = " (734) 555 1212\n"
+ " (734) 555.1212\n"
+ " (734) 555-1212\n"
+ " (734) 5551212\n"
+ " (734)5551212";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}