import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\\nclass\\s(.*?)(?=\\().*?model\\s=\\s(.*?)\\n.*?(?=fields.*?\\((.*?)\\)).*?(?=write_once_fields.*?\\((.*?)\\)).*?(?=required_fields.*?\\((.*?)\\))";
final String string = "import stuff\n\n"
+ "class ITEM1(BaseSerializer):\n"
+ " '''docstring'''\n"
+ " profile_id = None\n"
+ " house_id = None\n"
+ " # synopsis = ModelIDListField(source='synopsis', serializer=NotificationSerializer)\n"
+ " class Meta:\n"
+ " '''docstring'''\n"
+ "# model = Null\n"
+ " model = ITEM2\n"
+ " fields = (ITEM3)\n"
+ " # write_once_fields = (Null)\n"
+ " write_once_fields = (ITEM4)\n"
+ " required_fields = (ITEM5)\n"
+ " depth = 1\n\n"
+ "class ITEM1(HouseUserSerializer):\n"
+ " # synopsis = ModelIDListField(source='synopsis')\n"
+ " class Meta:\n"
+ "# model = Null\n"
+ " model = ITEM2\n"
+ " fields = (ITEM3)\n"
+ " required_fields = (ITEM5)\n"
+ " depth = 1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}