const regex = new RegExp('(?s)\\nclass\\s(.*?)(?=\\().*?model\\s=\\s(.*?)\\n.*?(?=fields.*?\\((.*?)\\)).*?(?=write_once_fields.*?\\((.*?)\\)).*?(?=required_fields.*?\\((.*?)\\))', 'g')
const str = `import stuff
class ITEM1(BaseSerializer):
'''docstring'''
profile_id = None
house_id = None
# synopsis = ModelIDListField(source='synopsis', serializer=NotificationSerializer)
class Meta:
'''docstring'''
# model = Null
model = ITEM2
fields = (ITEM3)
# write_once_fields = (Null)
write_once_fields = (ITEM4)
required_fields = (ITEM5)
depth = 1
class ITEM1(HouseUserSerializer):
# synopsis = ModelIDListField(source='synopsis')
class Meta:
# model = Null
model = ITEM2
fields = (ITEM3)
required_fields = (ITEM5)
depth = 1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}