import re
regex = re.compile(r"(?s)\nclass\s(.*?)(?=\().*?model\s=\s(.*?)\n.*?(?=fields.*?\((.*?)\)).*?(?=write_once_fields.*?\((.*?)\)).*?(?=required_fields.*?\((.*?)\))")
test_str = ("import stuff\n\n"
"class ITEM1(BaseSerializer):\n"
" '''docstring'''\n"
" profile_id = None\n"
" house_id = None\n"
" # synopsis = ModelIDListField(source='synopsis', serializer=NotificationSerializer)\n"
" class Meta:\n"
" '''docstring'''\n"
"# model = Null\n"
" model = ITEM2\n"
" fields = (ITEM3)\n"
" # write_once_fields = (Null)\n"
" write_once_fields = (ITEM4)\n"
" required_fields = (ITEM5)\n"
" depth = 1\n\n"
"class ITEM1(HouseUserSerializer):\n"
" # synopsis = ModelIDListField(source='synopsis')\n"
" class Meta:\n"
"# model = Null\n"
" model = ITEM2\n"
" fields = (ITEM3)\n"
" required_fields = (ITEM5)\n"
" depth = 1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")