re = /(?s)\nclass\s(.*?)(?=\().*?model\s=\s(.*?)\n.*?(?=fields.*?\((.*?)\)).*?(?=write_once_fields.*?\((.*?)\)).*?(?=required_fields.*?\((.*?)\))/
str = 'import stuff
class ITEM1(BaseSerializer):
\'\'\'docstring\'\'\'
profile_id = None
house_id = None
# synopsis = ModelIDListField(source=\'synopsis\', serializer=NotificationSerializer)
class Meta:
\'\'\'docstring\'\'\'
# model = Null
model = ITEM2
fields = (ITEM3)
# write_once_fields = (Null)
write_once_fields = (ITEM4)
required_fields = (ITEM5)
depth = 1
class ITEM1(HouseUserSerializer):
# synopsis = ModelIDListField(source=\'synopsis\')
class Meta:
# model = Null
model = ITEM2
fields = (ITEM3)
required_fields = (ITEM5)
depth = 1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end