using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<nummer>\d+)\s(?<stichwort>.*?\s)(?<alarmtext>(.*?\s+?)+)(?<strasse>.+)\s(?<hausnr>.+)\/\s(?<ortsteil>.*)$";
string input = @"1111 Stichwort Hier steht der Alarmtext Straße Hausnummer/ Ortsteil
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}