re = /^(?<nummer>\d+)\s(?<stichwort>.*?\s)(?<alarmtext>(.*?\s+?)+)(?<strasse>.+)\s(?<hausnr>.+)\/\s(?<ortsteil>.*)$/m
str = '1111 Stichwort Hier steht der Alarmtext Straße Hausnummer/ Ortsteil
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end