import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<nummer>\\d+)\\s(?<stichwort>.*?\\s)(?<alarmtext>(.*?\\s+?)+)(?<strasse>.+)\\s(?<hausnr>.+)\\/\\s(?<ortsteil>.*)$";
final String string = "1111 Stichwort Hier steht der Alarmtext Straße Hausnummer/ Ortsteil\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}