package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<nummer>\d+)\s(?<stichwort>.*?\s)(?<alarmtext>(.*?\s+?)+)(?<strasse>.+)\s(?<hausnr>.+)\/\s(?<ortsteil>.*)$`)
var str = `1111 Stichwort Hier steht der Alarmtext Straße Hausnummer/ Ortsteil
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}