const regex = /^(?<nummer>\d+)\s(?<stichwort>.*?\s)(?<alarmtext>(.*?\s+?)+)(?<strasse>.+)\s(?<hausnr>.+)\/\s(?<ortsteil>.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<nummer>\\d+)\\s(?<stichwort>.*?\\s)(?<alarmtext>(.*?\\s+?)+)(?<strasse>.+)\\s(?<hausnr>.+)\\\/\\s(?<ortsteil>.*)$', 'gm')
const str = `1111 Stichwort Hier steht der Alarmtext Straße Hausnummer/ Ortsteil
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}