# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.+)\s+-\s+(.+?) +[fF](t|eat(uring)?)?\.?([^([\])\n]+)(.+)?$/$1 Feat.$5 - $2$6/gm;t' <<< "Carbin & Sirmark - Sorry featuring Sevener
Kristjan Cash Cash - Take Me Home Feat. Bebe Rexha (Revoke Remix)
Dj E-nergy C - 21 - My Super-hero track! feat Dj Ass-hole
Flight Facilities - Heart Attack Feat. Owl Eyes (Snakehips Remix)
Flight Facilities - Heart Attack Feat. Owl Eyes [Snake--hips Remix]
Fedde Le Grand - Cinematic
Fedde Le Grand Feat. Denny White - Cinematic
Artist - Name - Track Name feat someone
Artist Name - Track-Name feat someone
Dj E- nergy C -21 - My Super-hero track! feat Dj Ass-hole
Dj E-nergy C-21 - My Super-hero track!"