use strict;
my $str = 'Carbin & Sirmark - Sorry featuring Sevener
Kristjan Cash Cash - Take Me Home Feat. Bebe Rexha (Revoke Remix)
Dj E-nergy C - 21 - My Super-hero track! feat Dj Ass-hole
Flight Facilities - Heart Attack Feat. Owl Eyes (Snakehips Remix)
Flight Facilities - Heart Attack Feat. Owl Eyes [Snake--hips Remix]
Fedde Le Grand - Cinematic
Fedde Le Grand Feat. Denny White - Cinematic
Artist - Name - Track Name feat someone
Artist Name - Track-Name feat someone
Dj E- nergy C -21 - My Super-hero track! feat Dj Ass-hole
Dj E-nergy C-21 - My Super-hero track!';
my $regex = qr/^(.+)\s+-\s+(.+?) +[fF](t|eat(uring)?)?\.?([^([\])\n]+)(.+)?$/mp;
my $subst = '$1 Feat.$5 - $2$6';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";