// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.+)\s+-\s+(.+?) +[fF](t|eat(uring)?)?\.?([^([\])\n]+)(.+)?$").unwrap();
let string = "Carbin & Sirmark - Sorry featuring Sevener
Kristjan Cash Cash - Take Me Home Feat. Bebe Rexha (Revoke Remix)
Dj E-nergy C - 21 - My Super-hero track! feat Dj Ass-hole
Flight Facilities - Heart Attack Feat. Owl Eyes (Snakehips Remix)
Flight Facilities - Heart Attack Feat. Owl Eyes [Snake--hips Remix]
Fedde Le Grand - Cinematic
Fedde Le Grand Feat. Denny White - Cinematic
Artist - Name - Track Name feat someone
Artist Name - Track-Name feat someone
Dj E- nergy C -21 - My Super-hero track! feat Dj Ass-hole
Dj E-nergy C-21 - My Super-hero track!";
let substitution = "$1 Feat.$5 - $2$6";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}