const regex = /^(.+)\s+-\s+(.+?) +[fF](t|eat(uring)?)?\.?([^([\])\n]+)(.+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.+)\\s+-\\s+(.+?) +[fF](t|eat(uring)?)?\\.?([^([\\])\\n]+)(.+)?$', 'gm')
const str = `Carbin & Sirmark - Sorry featuring Sevener
Kristjan Cash Cash - Take Me Home Feat. Bebe Rexha (Revoke Remix)
Dj E-nergy C - 21 - My Super-hero track! feat Dj Ass-hole
Flight Facilities - Heart Attack Feat. Owl Eyes (Snakehips Remix)
Flight Facilities - Heart Attack Feat. Owl Eyes [Snake--hips Remix]
Fedde Le Grand - Cinematic
Fedde Le Grand Feat. Denny White - Cinematic
Artist - Name - Track Name feat someone
Artist Name - Track-Name feat someone
Dj E- nergy C -21 - My Super-hero track! feat Dj Ass-hole
Dj E-nergy C-21 - My Super-hero track!`;
const subst = `$1 Feat.$5 - $2$6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);