const regex = /DTS.?(HD|ES|X(?!\D))|TRUEHD|ATMOS|DD(\+|P).?([5-9])|EAC3.?([5-9])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('DTS.?(HD|ES|X(?!\\D))|TRUEHD|ATMOS|DD(\\+|P).?([5-9])|EAC3.?([5-9])', 'gm')
const str = `#DTS matches
DTSHD
DTSES
DTSX5
DTS5HD
#DTS non-matches
DTSXXX
DTSA
#these two are just exact matches
TRUEHD
ATMOS
#they are found anywhere in the text
ATMOSPHERE
#DD matches
DD+5
DD+\$5 #here \$ is matched by .?
DD+45
DDP5
#DD non-matches
DD
DDA
DD+4
DDPx4
#EAC matches
EAC345
EAC35
#EAC non-matches
EAC34
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}