$re = '/DTS.?(HD|ES|X(?!\D))|TRUEHD|ATMOS|DD(\+|P).?([5-9])|EAC3.?([5-9])/m';
$str = '#DTS matches
DTSHD
DTSES
DTSX5
DTS5HD
#DTS non-matches
DTSXXX
DTSA
#these two are just exact matches
TRUEHD
ATMOS
#they are found anywhere in the text
ATMOSPHERE
#DD matches
DD+5
DD+$5 #here $ is matched by .?
DD+45
DDP5
#DD non-matches
DD
DDA
DD+4
DDPx4
#EAC matches
EAC345
EAC35
#EAC non-matches
EAC34
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);