# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"DTS.?(HD|ES|X(?!\D))|TRUEHD|ATMOS|DD(\+|P).?([5-9])|EAC3.?([5-9])"
test_str = ("#DTS matches\n"
"DTSHD\n"
"DTSES\n"
"DTSX5\n"
"DTS5HD\n"
"#DTS non-matches\n"
"DTSXXX\n"
"DTSA\n\n"
"#these two are just exact matches\n"
"TRUEHD\n"
"ATMOS\n"
"#they are found anywhere in the text\n"
"ATMOSPHERE\n\n"
"#DD matches\n"
"DD+5\n"
"DD+$5 #here $ is matched by .?\n"
"DD+45\n"
"DDP5\n"
"#DD non-matches\n"
"DD\n"
"DDA\n"
"DD+4\n"
"DDPx4\n\n"
"#EAC matches\n"
"EAC345\n"
"EAC35\n\n"
"#EAC non-matches\n"
"EAC34\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.