import Foundation
let pattern = #"DTS.?(HD|ES|X(?!\D))|TRUEHD|ATMOS|DD(\+|P).?([5-9])|EAC3.?([5-9])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
#DTS matches
DTSHD
DTSES
DTSX5
DTS5HD
#DTS non-matches
DTSXXX
DTSA
#these two are just exact matches
TRUEHD
ATMOS
#they are found anywhere in the text
ATMOSPHERE
#DD matches
DD+5
DD+$5 #here $ is matched by .?
DD+45
DDP5
#DD non-matches
DD
DDA
DD+4
DDPx4
#EAC matches
EAC345
EAC35
#EAC non-matches
EAC34
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)