using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\r\n]*\R)[^\r\n]*\R?";
string substitution = @"\1";
string input = @"foo
bar
test
123";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}