const regex = /([^\r\n]*\R)[^\r\n]*\R?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\r\\n]*\\R)[^\\r\\n]*\\R?', 'g')
const str = `foo
bar
test
123`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);