$re = '/([^\r\n]*\R)[^\r\n]*\R?/';
$str = 'foo
bar
test
123';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;