import re
regex = re.compile(r"([^\r\n]*\R)[^\r\n]*\R?")
test_str = ("foo\n"
"bar\n"
"test\n"
"123")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)