using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<product>[^*]+)\*(?<qty>[^,]+),?";
string input = @"30143*1,30144*2,30145*3,30146*5,30147*5";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}