re = /(?<product>[^*]+)\*(?<qty>[^,]+),?/
str = '30143*1,30144*2,30145*3,30146*5,30147*5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end