$re = '/(?<product>[^*]+)\*(?<qty>[^,]+),?/';
$str = '30143*1,30144*2,30145*3,30146*5,30147*5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);