// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<product>[^*]+)\*(?<qty>[^,]+),?").unwrap();
let string = "30143*1,30144*2,30145*3,30146*5,30147*5";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}