# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([\w\.\-]+)(?:\+[\w\.\-]+)?(@\w+(?:\.[\w\-]+)+)$/$1$2/gm;t' <<< "john.doe+1234@company.be"