re = /^([\w\.\-]+)(?:\+[\w\.\-]+)?(@\w+(?:\.[\w\-]+)+)$/m
str = 'john.doe+1234@company.be'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result