const regex = /^([\w\.\-]+)(?:\+[\w\.\-]+)?(@\w+(?:\.[\w\-]+)+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\w\\.\\-]+)(?:\\+[\\w\\.\\-]+)?(@\\w+(?:\\.[\\w\\-]+)+)$', 'gm')
const str = `john.doe+1234@company.be`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);