package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\w\.\-]+)(?:\+[\w\.\-]+)?(@\w+(?:\.[\w\-]+)+)$`)
var str = `john.doe+1234@company.be`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}