use strict;
my $str = 'john.doe+1234@company.be';
my $regex = qr/^([\w\.\-]+)(?:\+[\w\.\-]+)?(@\w+(?:\.[\w\-]+)+)$/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";