#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^([01]?\d{0,4}|20000)$"
Local $sString = "12" & @CRLF & _
"1" & @CRLF & _
"1234" & @CRLF & _
"123" & @CRLF & _
"12344" & @CRLF & _
"123212" & @CRLF & _
"20000" & @CRLF & _
"19999" & @CRLF & _
"2000" & @CRLF & _
"200" & @CRLF & _
"200"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")