package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([01]?\d{0,4}|20000)$`)
var str = `12
1
1234
123
12344
123212
20000
19999
2000
200
200`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}