const regex = /^([01]?\d{0,4}|20000)$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([01]?\\d{0,4}|20000)$', 'gmi')
const str = `12
1
1234
123
12344
123212
20000
19999
2000
200
200`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}