$re = '/^([01]?\d{0,4}|20000)$/mi';
$str = '12
1
1234
123
12344
123212
20000
19999
2000
200
200';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);