re = /^([01]?\d{0,4}|20000)$/mi
str = '12
1
1234
123
12344
123212
20000
19999
2000
200
200'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end