#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)是(.*色)"
Local $sString = "苹果是绿色的" & @CRLF & _
"橙子是橙色的" & @CRLF & _
"香蕉是黄色的" & @CRLF & _
"乌鸦是黑色的" & @CRLF & _
"乌鸦是黄棕色的"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")